buildozer.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452
  1. [app]
  2. # (str) Title of your application
  3. title = STI2021A
  4. # (str) Package name
  5. package.name = debug
  6. # (str) Package domain (needed for android/ios packaging)
  7. package.domain = org.test
  8. # (str) Source code where the main.py live
  9. source.dir = .
  10. # (list) Source files to include (let empty to include all the files)
  11. source.include_exts = py,png,jpg,kv,atlas
  12. # (list) List of inclusions using pattern matching
  13. #source.include_patterns = assets/*,images/*.png
  14. # (list) Source files to exclude (let empty to not exclude anything)
  15. #source.exclude_exts = spec
  16. # (list) List of directory to exclude (let empty to not exclude anything)
  17. #source.exclude_dirs = tests, bin, venv
  18. # (list) List of exclusions using pattern matching
  19. # Do not prefix with './'
  20. #source.exclude_patterns = license,images/*/*.jpg
  21. # (str) Application versioning (method 1)
  22. version = 1.0
  23. # (str) Application versioning (method 2)
  24. # version.regex = __version__ = ['"](.*)['"]
  25. # version.filename = %(source.dir)s/main.py
  26. # (list) Application requirements
  27. # comma separated e.g. requirements = sqlite3,kivy
  28. requirements = python3,kivy,bleak
  29. # (str) Custom source folders for requirements
  30. # Sets custom source for any requirements with recipes
  31. # requirements.source.kivy = ../../kivy
  32. # (str) Presplash of the application
  33. #presplash.filename = %(source.dir)s/data/presplash.png
  34. # (str) Icon of the application
  35. #icon.filename = %(source.dir)s/data/icon.png
  36. # (list) Supported orientations
  37. # Valid options are: landscape, portrait, portrait-reverse or landscape-reverse
  38. orientation = portrait
  39. # (list) List of service to declare
  40. #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY
  41. #
  42. # OSX Specific
  43. #
  44. #
  45. # author = © Copyright Info
  46. # change the major version of python used by the app
  47. osx.python_version = 3
  48. # Kivy version to use
  49. osx.kivy_version = 1.9.1
  50. #
  51. # Android specific
  52. #
  53. # (bool) Indicate if the application should be fullscreen or not
  54. fullscreen = 0
  55. # (string) Presplash background color (for android toolchain)
  56. # Supported formats are: #RRGGBB #AARRGGBB or one of the following names:
  57. # red, blue, green, black, white, gray, cyan, magenta, yellow, lightgray,
  58. # darkgray, grey, lightgrey, darkgrey, aqua, fuchsia, lime, maroon, navy,
  59. # olive, purple, silver, teal.
  60. #android.presplash_color = #FFFFFF
  61. # (string) Presplash animation using Lottie format.
  62. # see https://lottiefiles.com/ for examples and https://airbnb.design/lottie/
  63. # for general documentation.
  64. # Lottie files can be created using various tools, like Adobe After Effect or Synfig.
  65. #android.presplash_lottie = "path/to/lottie/file.json"
  66. # (str) Adaptive icon of the application (used if Android API level is 26+ at runtime)
  67. #icon.adaptive_foreground.filename = %(source.dir)s/data/icon_fg.png
  68. #icon.adaptive_background.filename = %(source.dir)s/data/icon_bg.png
  69. # (list) Permissions
  70. # (See https://python-for-android.readthedocs.io/en/latest/buildoptions/#build-options-1 for all the supported syntaxes and properties)
  71. #android.permissions = android.permission.INTERNET, (name=android.permission.WRITE_EXTERNAL_STORAGE;maxSdkVersion=18)
  72. # (list) features (adds uses-feature -tags to manifest)
  73. #android.features = android.hardware.usb.host
  74. # (int) Target Android API, should be as high as possible.
  75. #android.api = 31
  76. # (int) Minimum API your APK / AAB will support.
  77. #android.minapi = 21
  78. # (int) Android SDK version to use
  79. #android.sdk = 20
  80. # (str) Android NDK version to use
  81. #android.ndk = 23b
  82. # (int) Android NDK API to use. This is the minimum API your app will support, it should usually match android.minapi.
  83. #android.ndk_api = 21
  84. # (bool) Use --private data storage (True) or --dir public storage (False)
  85. #android.private_storage = True
  86. # (str) Android NDK directory (if empty, it will be automatically downloaded.)
  87. #android.ndk_path =
  88. # (str) Android SDK directory (if empty, it will be automatically downloaded.)
  89. #android.sdk_path =
  90. # (str) ANT directory (if empty, it will be automatically downloaded.)
  91. #android.ant_path =
  92. # (bool) If True, then skip trying to update the Android sdk
  93. # This can be useful to avoid excess Internet downloads or save time
  94. # when an update is due and you just want to test/build your package
  95. # android.skip_update = False
  96. # (bool) If True, then automatically accept SDK license
  97. # agreements. This is intended for automation only. If set to False,
  98. # the default, you will be shown the license when first running
  99. # buildozer.
  100. # android.accept_sdk_license = False
  101. # (str) Android entry point, default is ok for Kivy-based app
  102. #android.entrypoint = org.kivy.android.PythonActivity
  103. # (str) Full name including package path of the Java class that implements Android Activity
  104. # use that parameter together with android.entrypoint to set custom Java class instead of PythonActivity
  105. #android.activity_class_name = org.kivy.android.PythonActivity
  106. # (str) Extra xml to write directly inside the <manifest> element of AndroidManifest.xml
  107. # use that parameter to provide a filename from where to load your custom XML code
  108. #android.extra_manifest_xml = ./src/android/extra_manifest.xml
  109. # (str) Extra xml to write directly inside the <manifest><application> tag of AndroidManifest.xml
  110. # use that parameter to provide a filename from where to load your custom XML arguments:
  111. #android.extra_manifest_application_arguments = ./src/android/extra_manifest_application_arguments.xml
  112. # (str) Full name including package path of the Java class that implements Python Service
  113. # use that parameter to set custom Java class which extends PythonService
  114. #android.service_class_name = org.kivy.android.PythonService
  115. # (str) Android app theme, default is ok for Kivy-based app
  116. # android.apptheme = "@android:style/Theme.NoTitleBar"
  117. # (list) Pattern to whitelist for the whole project
  118. #android.whitelist =
  119. # (str) Path to a custom whitelist file
  120. #android.whitelist_src =
  121. # (str) Path to a custom blacklist file
  122. #android.blacklist_src =
  123. # (list) List of Java .jar files to add to the libs so that pyjnius can access
  124. # their classes. Don't add jars that you do not need, since extra jars can slow
  125. # down the build process. Allows wildcards matching, for example:
  126. # OUYA-ODK/libs/*.jar
  127. #android.add_jars = foo.jar,bar.jar,path/to/more/*.jar
  128. # (list) List of Java files to add to the android project (can be java or a
  129. # directory containing the files)
  130. #android.add_src =
  131. # (list) Android AAR archives to add
  132. #android.add_aars =
  133. # (list) Put these files or directories in the apk assets directory.
  134. # Either form may be used, and assets need not be in 'source.include_exts'.
  135. # 1) android.add_assets = source_asset_relative_path
  136. # 2) android.add_assets = source_asset_path:destination_asset_relative_path
  137. #android.add_assets =
  138. # (list) Put these files or directories in the apk res directory.
  139. # The option may be used in three ways, the value may contain one or zero ':'
  140. # Some examples:
  141. # 1) A file to add to resources, legal resource names contain ['a-z','0-9','_']
  142. # android.add_resources = my_icons/all-inclusive.png:drawable/all_inclusive.png
  143. # 2) A directory, here 'legal_icons' must contain resources of one kind
  144. # android.add_resources = legal_icons:drawable
  145. # 3) A directory, here 'legal_resources' must contain one or more directories,
  146. # each of a resource kind: drawable, xml, etc...
  147. # android.add_resources = legal_resources
  148. #android.add_resources =
  149. # (list) Gradle dependencies to add
  150. #android.gradle_dependencies =
  151. # (bool) Enable AndroidX support. Enable when 'android.gradle_dependencies'
  152. # contains an 'androidx' package, or any package from Kotlin source.
  153. # android.enable_androidx requires android.api >= 28
  154. #android.enable_androidx = True
  155. # (list) add java compile options
  156. # this can for example be necessary when importing certain java libraries using the 'android.gradle_dependencies' option
  157. # see https://developer.android.com/studio/write/java8-support for further information
  158. # android.add_compile_options = "sourceCompatibility = 1.8", "targetCompatibility = 1.8"
  159. # (list) Gradle repositories to add {can be necessary for some android.gradle_dependencies}
  160. # please enclose in double quotes
  161. # e.g. android.gradle_repositories = "maven { url 'https://kotlin.bintray.com/ktor' }"
  162. #android.add_gradle_repositories =
  163. # (list) packaging options to add
  164. # see https://google.github.io/android-gradle-dsl/current/com.android.build.gradle.internal.dsl.PackagingOptions.html
  165. # can be necessary to solve conflicts in gradle_dependencies
  166. # please enclose in double quotes
  167. # e.g. android.add_packaging_options = "exclude 'META-INF/common.kotlin_module'", "exclude 'META-INF/*.kotlin_module'"
  168. #android.add_packaging_options =
  169. # (list) Java classes to add as activities to the manifest.
  170. #android.add_activities = com.example.ExampleActivity
  171. # (str) OUYA Console category. Should be one of GAME or APP
  172. # If you leave this blank, OUYA support will not be enabled
  173. #android.ouya.category = GAME
  174. # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
  175. #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
  176. # (str) XML file to include as an intent filters in <activity> tag
  177. #android.manifest.intent_filters =
  178. # (list) Copy these files to src/main/res/xml/ (used for example with intent-filters)
  179. #android.res_xml = PATH_TO_FILE,
  180. # (str) launchMode to set for the main activity
  181. #android.manifest.launch_mode = standard
  182. # (str) screenOrientation to set for the main activity.
  183. # Valid values can be found at https://developer.android.com/guide/topics/manifest/activity-element
  184. #android.manifest.orientation = fullSensor
  185. # (list) Android additional libraries to copy into libs/armeabi
  186. #android.add_libs_armeabi = libs/android/*.so
  187. #android.add_libs_armeabi_v7a = libs/android-v7/*.so
  188. #android.add_libs_arm64_v8a = libs/android-v8/*.so
  189. #android.add_libs_x86 = libs/android-x86/*.so
  190. #android.add_libs_mips = libs/android-mips/*.so
  191. # (bool) Indicate whether the screen should stay on
  192. # Don't forget to add the WAKE_LOCK permission if you set this to True
  193. #android.wakelock = False
  194. # (list) Android application meta-data to set (key=value format)
  195. #android.meta_data =
  196. # (list) Android library project to add (will be added in the
  197. # project.properties automatically.)
  198. #android.library_references =
  199. # (list) Android shared libraries which will be added to AndroidManifest.xml using <uses-library> tag
  200. #android.uses_library =
  201. # (str) Android logcat filters to use
  202. #android.logcat_filters = *:S python:D
  203. # (bool) Android logcat only display log for activity's pid
  204. #android.logcat_pid_only = False
  205. # (str) Android additional adb arguments
  206. #android.adb_args = -H host.docker.internal
  207. # (bool) Copy library instead of making a libpymodules.so
  208. #android.copy_libs = 1
  209. # (list) The Android archs to build for, choices: armeabi-v7a, arm64-v8a, x86, x86_64
  210. # In past, was `android.arch` as we weren't supporting builds for multiple archs at the same time.
  211. android.archs = arm64-v8a, armeabi-v7a
  212. # (int) overrides automatic versionCode computation (used in build.gradle)
  213. # this is not the same as app version and should only be edited if you know what you're doing
  214. # android.numeric_version = 1
  215. # (bool) enables Android auto backup feature (Android API >=23)
  216. android.allow_backup = True
  217. # (str) XML file for custom backup rules (see official auto backup documentation)
  218. # android.backup_rules =
  219. # (str) If you need to insert variables into your AndroidManifest.xml file,
  220. # you can do so with the manifestPlaceholders property.
  221. # This property takes a map of key-value pairs. (via a string)
  222. # Usage example : android.manifest_placeholders = [myCustomUrl:\"org.kivy.customurl\"]
  223. # android.manifest_placeholders = [:]
  224. # (bool) Skip byte compile for .py files
  225. # android.no-byte-compile-python = False
  226. # (str) The format used to package the app for release mode (aab or apk or aar).
  227. # android.release_artifact = aab
  228. # (str) The format used to package the app for debug mode (apk or aar).
  229. # android.debug_artifact = apk
  230. #
  231. # Python for android (p4a) specific
  232. #
  233. # (str) python-for-android URL to use for checkout
  234. #p4a.url =
  235. # (str) python-for-android fork to use in case if p4a.url is not specified, defaults to upstream (kivy)
  236. #p4a.fork = kivy
  237. # (str) python-for-android branch to use, defaults to master
  238. #p4a.branch = master
  239. # (str) python-for-android specific commit to use, defaults to HEAD, must be within p4a.branch
  240. #p4a.commit = HEAD
  241. # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
  242. #p4a.source_dir =
  243. # (str) The directory in which python-for-android should look for your own build recipes (if any)
  244. p4a.local_recipes = home/jam/Projects/bleak/backends/p4android/recipes
  245. # (str) Filename to the hook for p4a
  246. #p4a.hook =
  247. # (str) Bootstrap to use for android builds
  248. # p4a.bootstrap = sdl2
  249. # (int) port number to specify an explicit --port= p4a argument (eg for bootstrap flask)
  250. #p4a.port =
  251. # Control passing the --use-setup-py vs --ignore-setup-py to p4a
  252. # "in the future" --use-setup-py is going to be the default behaviour in p4a, right now it is not
  253. # Setting this to false will pass --ignore-setup-py, true will pass --use-setup-py
  254. # NOTE: this is general setuptools integration, having pyproject.toml is enough, no need to generate
  255. # setup.py if you're using Poetry, but you need to add "toml" to source.include_exts.
  256. #p4a.setup_py = false
  257. # (str) extra command line arguments to pass when invoking pythonforandroid.toolchain
  258. #p4a.extra_args =
  259. #
  260. # iOS specific
  261. #
  262. # (str) Path to a custom kivy-ios folder
  263. #ios.kivy_ios_dir = ../kivy-ios
  264. # Alternately, specify the URL and branch of a git checkout:
  265. ios.kivy_ios_url = https://github.com/kivy/kivy-ios
  266. ios.kivy_ios_branch = master
  267. # Another platform dependency: ios-deploy
  268. # Uncomment to use a custom checkout
  269. #ios.ios_deploy_dir = ../ios_deploy
  270. # Or specify URL and branch
  271. ios.ios_deploy_url = https://github.com/phonegap/ios-deploy
  272. ios.ios_deploy_branch = 1.10.0
  273. # (bool) Whether or not to sign the code
  274. ios.codesign.allowed = false
  275. # (str) Name of the certificate to use for signing the debug version
  276. # Get a list of available identities: buildozer ios list_identities
  277. #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
  278. # (str) The development team to use for signing the debug version
  279. #ios.codesign.development_team.debug = <hexstring>
  280. # (str) Name of the certificate to use for signing the release version
  281. #ios.codesign.release = %(ios.codesign.debug)s
  282. # (str) The development team to use for signing the release version
  283. #ios.codesign.development_team.release = <hexstring>
  284. # (str) URL pointing to .ipa file to be installed
  285. # This option should be defined along with `display_image_url` and `full_size_image_url` options.
  286. #ios.manifest.app_url =
  287. # (str) URL pointing to an icon (57x57px) to be displayed during download
  288. # This option should be defined along with `app_url` and `full_size_image_url` options.
  289. #ios.manifest.display_image_url =
  290. # (str) URL pointing to a large icon (512x512px) to be used by iTunes
  291. # This option should be defined along with `app_url` and `display_image_url` options.
  292. #ios.manifest.full_size_image_url =
  293. [buildozer]
  294. # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
  295. log_level = 2
  296. # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
  297. warn_on_root = 1
  298. # (str) Path to build artifact storage, absolute or relative to spec file
  299. # build_dir = ./.buildozer
  300. # (str) Path to build output (i.e. .apk, .aab, .ipa) storage
  301. # bin_dir = ./bin
  302. # -----------------------------------------------------------------------------
  303. # List as sections
  304. #
  305. # You can define all the "list" as [section:key].
  306. # Each line will be considered as a option to the list.
  307. # Let's take [app] / source.exclude_patterns.
  308. # Instead of doing:
  309. #
  310. #[app]
  311. #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
  312. #
  313. # This can be translated into:
  314. #
  315. #[app:source.exclude_patterns]
  316. #license
  317. #data/audio/*.wav
  318. #data/images/original/*
  319. #
  320. # -----------------------------------------------------------------------------
  321. # Profiles
  322. #
  323. # You can extend section / key with a profile
  324. # For example, you want to deploy a demo version of your application without
  325. # HD content. You could first change the title to add "(demo)" in the name
  326. # and extend the excluded directories to remove the HD content.
  327. #
  328. #[app@demo]
  329. #title = My Application (demo)
  330. #
  331. #[app:source.exclude_patterns@demo]
  332. #images/hd/*
  333. #
  334. # Then, invoke the command line with the "demo" profile:
  335. #
  336. #buildozer --profile demo android debug